-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Frugalware-Art.org Artwork for Frugalware Linux 
 Arch-Stuff.org Artwork and Stuff for Arch Linux 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    Linux42.org    OpenSkillz.com   
LinuxMint-Art.org - Eyecandy for LinuxMint
LinuxMint-Art.orgLinuxMint-Art.org

 Aug 30 2016  
 Not logged in  
LinuxMint-Art.org
 Home    Add Artwork   Forum   Groups   Knowledge   Events   Jobs   Users   Register   Login-


Sponsoring


-
- Content .- Fans (6) .- Knowledge Base (1) . 

Kvantum

  

Theme/Style for KDE 4.0

Score 64%
Kvantum
zoom


Kvantum
zoom


Homepage:  Link
Downloads:  8505
Submitted:  Jul 19 2014
Updated:  Nov 19 2014

Description:

Kvantum is an SVG-based theme engine for Qt4/Qt5 and KDE, i.e. a program for styling Qt applications with SVG images, with an emphasis on elegance, usability and practicality.

Kvantum comes with a default dark theme, inspired by the default theme of Enlightenment. Creation of realistic themes like that for KDE was my first reason to make Kvantum but it allows themes with very different looks and feels, whether they be photorealistic or cartoonish, 3D or flat, embellished or minimalistic, or something in between.

Kvantum also has extra themes, that are installed as root with Qt5 installation and can be selected and activated by using Kvantum Manager.

The core idea of Kvantum, namely using of SVG images for drawing Qt widgets, is taken from QuantumStyle (not developed anymore but continued as QSvgStyle at https://github.com/DexterMagnific/QSvgStyle).

*** Compilation and Installation ***

Please read the file INSTALL for detailed instructions on compilation and installation for Qt4 and Qt5!

For 64-bit Debian Testing (and, perhaps, other 64-bit Debian-based systems too), you could just use the deb package(s) at https://github.com/tsujan/Kvantum/releases. There is also a link to 32 and 64-bit Arch packages, kindly made by Josip (metak), in the Files section of this page.

*** Theme Making ***

For instructions on how to change configuration or make new themes, please read the files Theme-Config and Theme-Making in the doc folder!

*** Notes ***

(1) Each new theme should be accompanied by a KDE color scheme because some KDE apps may use colors specific to KDE. Qt apps use Kvantum colors though.

(2) Kvantum does not provide window decorations. Such jobs are done by the window manager.

(3) For the latest and other releases, please go to the home page! This page may not be up-to-date.




Changelog:

See ChangeLog inside the source for a thorough list.




LicenseGPL
(64-bit Debian Testing and Ubuntu)
(Source at GitHub)
(32 and 64-bit Arch -- Thanks to Josip (metak))
Send to a friend
Subscribe
Other  Artwork  from tsujan
Report inappropriate content



goto page: prev   1  2  3  4  5 

-

 Kvantum qt5 on Jessie

 
 by stevepusser on: May 18 2016
 
Score 50%

I set up a separate kvantum-qt5 package that built correctly, and I had it build and install the resulting .so file in the same qt5 plugin directory as your deb, but qt5 apps just looked the same--not showing Kvantum themes at all.

It makes me wonder if it's related to the same problem that the qt5-configure ( http://qt-apps.org/content/show.php/Qt5+Configuration+Tool?content=168066 ) tool has: you can build it with the Qt 5.3 in Jessie, but it also has no effect. Seems that Qt 5.4 fixed something fundamental.

I'll try your debian folder--I have no problem with the build-depends having possibly different names. That's what the alternative "|" is for:

Build-Depends: foo-dev | foo1-dev | foo2-dev,


Reply to this

-

 Re: Kvantum qt5 on Jessie

 
 by stevepusser on: May 18 2016
 
Score 50%

On testing, I found out that the kvantum 0.9.6 won't build on Qt 5.3, because it needs the qxcbwindowfunctions headers, and 5.3 doesn't have that.

I did find out how to make your rules file arch-independent instead of amd64-only.

First, you can just use "qmake-qt4" as the qt4 qmake, because there's a symlink in /usr/bin to it, so you don't have to call out the whole path.

For the qt 5 qmake, add this line at the start of the rules file:

DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)

so then the line calling out the qt5 qmake becomes:
cd builddir && /usr/lib/$(DEB_HOST_MULTIARCH)/qt5/bin/qmake PREFIX=/usr ../$(APPNAME).pro

I might try and see how that works in OBS for the Ubuntu versions that have a newer Qt 5.


Reply to this

-

 Re: Kvantum qt5 on Jessie

 
 by tsujan on: May 18 2016
 
Score 50%

Strange! The specific header `qxcbwindowfunctions.h` isn't used by Kvantum.

I don't think Jessie has a DE that recognizes Qt5 style plugins automatically. You should use one of the methods explained in INSTALL.

Thanks for the arch-independent tip! I only build 64-bit packages because I can test them.


Reply to this

-

 Re: Re: Kvantum qt5 on Jessie

 
 by stevepusser on: May 19 2016
 
Score 50%

Hmmm...let's see if I can find the specific build error with qt 5.

If you provided an arch-independent debian folder, than anyone using Debian or Ubuntu on any architecture could build their own packages, following the rather simple steps for rebuilding from debian source. Then it's up for them to test it. ;)


Reply to this

-

 Re: Re: Kvantum qt5 on Jessie

 
 by stevepusser on: May 19 2016
 
Score 50%

OK...I get this error

Kvantum.cpp:60:49: fatal error: QtPlatformHeaders/QXcbWindowFunctions: No such file or directory

which is due to line 60 in Kvantum.cpp

#include <QtPlatformHeaders/QXcbWindowFunctions>


Reply to this

-

 Re: Re: Re: Kvantum qt5 on Jessie

 
 by tsujan on: May 19 2016
 
Score 50%

Oh, now I remember! Thanks for reporting! That's because of a workaround I included in Kvantum for QTBUG-47043. If I remove it for Qt < 5.5, Kvantum should be compiled against Qt-5.3 too. Please test again after I make a commit in GitHub (see the title of the latest commit) and tell me about the result! Thanks in advance!

As for the Debian folder, you're right. But, although I use Debian, I don't like to make an exception for Debian based systems. What about Arch-based systems (I like them very much) or rpm-based system? Should I include build folders/files for them too? I don't think so -- at least, not yet.


Reply to this

-

 Re: Re: Kvantum qt5 on Jessie

 
 by stevepusser on: May 19 2016
 
Score 50%

OK...I get this error

Kvantum.cpp:60:49: fatal error: QtPlatformHeaders/QXcbWindowFunctions: No such file or directory

which is due to line 60 in Kvantum.cpp

#include <QtPlatformHeaders/QXcbWindowFunctions>


Reply to this

-

 Re: Re: Re: Kvantum qt5 on Jessie

 
 by tsujan on: May 19 2016
 
Score 50%

Please read my reply above!


Reply to this

-

 Re: Re: Re: Re: Kvantum qt5 on Jessie

 
 by stevepusser on: May 21 2016
 
Score 50%

Oops, sorry for the double post. (bag over head)

Your commit does fix the compilation on Qt 5.3.

Anyway, I do already have a Qt 4-only Debian Kvantum package in the MX 15 repository, I'll switch out my current tiny qt4 dephelper rules file for the bigger multiarch one that'll do both, and see if that fixes anything on Jessie for qt5. At least people could grab those debianized sources if they want to rebuild it.


Reply to this

-

 Re: Re: Re: Re: Re: Kvantum qt5 on Jessie

 
 by stevepusser on: May 22 2016
 
Score 50%

Yeah, confirmed that configuring the styles on qt5 5.3 just doesn't work. Also, you don't have to specify dependencies for the finished package in the debian/control file, the ${shlibs:Depends} variable handles all that automatically--I ended up with automatically generated dependencies: libc6 (>= 2.14), libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libqt4-svg (>= 4:4.5.3), libqt5core5a (>= 5.0.2), libqt5gui5 (>= 5.2.0), libqt5svg5 (>= 5.0.2), libqt5widgets5 (>= 5.0.2), libqt5x11extras5 (>= 5.1.0), libqtcore4 (>= 4:4.8.0), libqtgui4 (>= 4:4.8.0), libstdc++6 (>= 4.1.1), libx11-6, libxext6.

Anyway, to also match other similar packages in Debian, I also renamed the package "kde-style-kvantum" in my packaging, and added a patch to make the GUI programs qt4 instead of qt5, since the qt5 versions are broken in Jessie. Just delete the debian/patches folder if your qt5 is new enough to work correctly. Here's my debian folder: https://drive.google.com/open?id=0BxE7wbgixC4GTDZ1Zlo2WTU3Uzg


Reply to this

-

 Re: Re: Re: Re: Re: Re: Kvantum qt5 on Jessie

 
 by tsujan on: May 22 2016
 
Score 50%

> Also, you don't have to specify dependencies for the finished package in the debian/control file

That was intentional: deb packages built against Qt >= 5.5.1 didn't work well in systems with Qt-5.5.0.



-

 Re: Re: Re: Re: Re: Re: Kvantum qt5 on Jessie

 
 by tsujan on: May 22 2016
 
Score 50%

BTW, as the .pro files are made for systems with Qt5 as their default Qt (i.e. most systems), Kvantum Manager and the extra themes won't be installed if the default Qt is Qt4. You should either compile them separately from their own folders or edit 'kvantum.pro'.



-

 Re: Re: Re: Re: Re: Re: Kvantum qt5 on Jessie

 
 by stevepusser on: May 25 2016
 
Score 50%

Quote:
BTW, as the .pro files are made for systems with Qt5 as their default Qt (i.e. most systems), Kvantum Manager and the extra themes won't be installed if the default Qt is Qt4. You should either compile them separately from their own folders or edit 'kvantum.pro'.


That's what the patch does to the .pro file during the build, for systems like Jessie that have to use the qt4 ones, because qt 5.3 won't work. The Debian packaging system doesn't let maintainers change original source, except in the form of patches that get applied only for the build. The debian/patches folder can safely be removed for systems with a working qt5.



-

 Re: Re: Re: Re: Re: Re: Kvantum qt5 on Jessie

 
 by stevepusser on: Jun 9 2016
 
Score 50%

Anyway...I set up a Jessie OBS repo with a backported Qt 5 5.5.1 backported from Debian testing, as well as a newer python-qt5 and python-sip that was required, then also added kde-style-kvantum and qt5ct. The newer Qt 5, as expected, does allow for Kvantum theming for both Qt4 and 5.

Instructions: https://software.opensuse.org/download.html?project=home%3Astevenpusser%3Aqmplay2%3Aqt5-default&package=qt5-default

Use with due caution, and don't use if it looks like it's going to remove something you need. Calibre depends on an exact version of Qt5 that it was build against, so I included that in the repo.


Reply to this

-

 Re: Re: Re: Re: Re: Re: Re: Kvantum qt5 on Jessie

 
 by tsujan on: Jun 9 2016
 
Score 50%

Thanks for your contribution!


Reply to this

goto page: prev   1  2  3  4  5 

Add commentBack






-

Copyright 2008-2016 LinuxMint-Art.org Team  Legal Notice
All rights reserved. LinuxMint-Art.org is not liable for any content or goods on this site.
You can find our FAQ here.
All contributors are responsible for the lawfulness of their uploads.
Please send us a notice if you spot an ABUSE of the website.
Information about advertising in LinuxMint-Art.org.
Developers can use our public webservice interface. More information here: public api
For further information or comments on this site, please send us a message
.
Content RSS   
Events RSS